Back to overview
Degraded

[IDENTIFIED] SSL Order Processing Issue

Jul 11 at 09:30am CEST
Affected services
SSL Panel

Resolved
Jul 11 at 06:03pm CEST

[RESOLVED] We have received confirmation from the SSL provider that the issue has been resolved. SSL orders are now processing as expected. Thank you for your patience.

Updated
Jul 11 at 12:30pm CEST

[IDENTIFIED] We have received confirmation from the SSL provider that they have identified the issue and are actively working on a resolution.

We sincerely apologize for any inconvenience this may have caused and truly appreciate your patience. We will share more updates as soon as we have them.

Created
Jul 11 at 09:30am CEST

Incident Description:
We are currently experiencing technical issues with our SSL provider. As a result, SSL orders cannot be processed at this time.

Impact:
Customers attempting to place SSL orders may face errors or interruptions. We understand the importance of SSL for your security and are working diligently to resolve the issue.

Current Status:
We have identified that the issue originates on our SSL provider's side and are in contact with their technical team to assist with resolution. Our team is actively monitoring the situation and will provide updates as they become available.