Back to overview
Downtime

[RESOLVED] EasyDMARC Dashboard access problem

Aug 22 at 10:00am CEST
Affected services
dmarcprotect.me

Resolved
Aug 22 at 11:00am CEST

[RESOLVED] We are pleased to inform that the EasyDMARC dashboard access from Reseller Control Panel (RCP) has been fixed. Thank you for your patience.

Created
Aug 22 at 10:00am CEST

The EasyDMARC dashboard access from Reseller Control Panel (RCP) is currently unavailable. This issue is related to our internal service. We're working on fixing the issue and dashboard access will be available again very soon.