Back to overview
[RESOLVED] Outgoing emails are not delivering
Aug 23 at 06:38am CEST
Affected services
Control Panel
Resolved
Aug 23 at 06:38am CEST
[Resolved] We are pleased to inform that the outgoing emails are not delivering issue has been fixed. Thank you for your patience.
Affected services