Back to overview
Degraded
[Issue].la Registration Failing
Aug 27 at 06:24am CEST
Affected services
Control Panel
Created
Aug 27 at 06:24am CEST
We are currently experiencing failures with .la domain registrations. Our team is actively working with the registry to resolve the issue.
We will provide updates as soon as more information becomes available.
Affected services