Spamexperts service outrage
Resolved
Jan 06 at 09:27am CET
Spameexperts service has resumed normal operations since yesterday and we have been actively monitoring the situation to ensure that everything is running smoothly.
Affected services
Updated
Jan 05 at 11:42am CET
SpamExperts Cloud Service Outage
We are continuing to experience issues affecting email delivery via the SpamExperts Cloud service. Our team is actively working with SpamExperts support to resolve the problem. We will provide updates as more information becomes available.
Affected services
Created
Jan 03 at 01:56pm CET
Hello Client,
We are pleased to inform you that the issue with emails not being received has been addressed, and the Spam Expert team is currently working on a fix.
Affected services