DNSSEC errors on some .eu domains (Premium DNS – Sectigo)
Updated
Jan 21 at 10:24am CET
[UPDATE] The issue is now confirmed to be affecting non-.eu domains as well.
We have received an update from Sectigo confirming a problem with the processing of webhooks and email notifications related to DNSSEC key rotation, which can lead to DNSSEC validation errors and resolution issues.
Sectigo is actively working on a fix and expects to have it deployed today. We will continue to monitor the situation and provide further updates as they become available.
Affected services
Created
Jan 20 at 01:15pm CET
Some domains using our Premium DNS are not resolving for certain ISPs/resolvers due to DNSSEC validation errors.
We are working with our upstream provider to investigate.
Temporary workaround: Disable DNSSEC on affected domains to restore resolution until further updates.
Affected services