Investigating issue with DNSSEC rotation - Premium DNS service
Updated
Apr 6, 2026 at 6:16am UTC
DNSSEC keys have been successfully rotated for all affected domains, which should resolve the existing cases. We are actively working on identifying and fixing the underlying root cause to prevent future occurrences.
Affected services
Updated
Mar 31, 2026 at 5:26am UTC
Due to an issue with DNSSEC key rotation from our supplier, some domains may continue using expired DNSSEC keys. This can lead to DNS validation failures and temporary website downtime. This issue does not affect all domains, and only occurs when DNSSEC keys are due for rotation. Only a certain set of dnssec-enabled domains are affected, and not all of them.
Workaround:
If you experience issues with your domain:
a. Temporarily disable DNSSEC - this can be done from your RCP, by editing domain details. Or, you can just send an email to support.
We are actively working with our supplier to resolve this issue and will provide updates as more information becomes available.
Affected services
Created
Mar 30, 2026 at 11:49am UTC
We are aware of an issue with DNSSEC rotation in our premium DNS service. We have engaged the provider’s support team and are currently investigating.
We will share additional updates as soon as we have more information.
Affected services