Back to overview
Degraded

[Fixed] Google Registry Domain Check Issue

Apr 8, 2026 at 7:00am UTC
Affected services
XML API
REST API

Resolved
Apr 8, 2026 at 7:55am UTC

[Fixed] Our development team has applied a patch to fix the domain check issue. Domain checks should now be working normally.

Created
Apr 8, 2026 at 7:00am UTC

We have identified an issue with domain check requests to the Google registry (TLDs - .app, .dev, .zip, .day, .rsvp, .mov, etc). This is affecting domain checks via both API and RCP (Reseller Control Panel). Our team is investigating and will apply a patch to restore functionality. We will share another update within the next hour.